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 VS2K5 First Use Message

Problem

When Visual Studio 2005 is used with Roaming Profiles, there's a high probability users will receive the "Visual Studio 2005 is configuring the environment for first time use. This might take a few minutes." message on every session startup. This takes a long time and slows students down.

Cause

This is a known problem with Visual Studio 2005, and not (we're happy to say!) a problem with ITEE's Student Network.
See item 1.4 on this page: http://msdn.microsoft.com/vstudio/express/support/issues/

Solution

Microsoft has not graced us with a solution as yet, but has provided a workaround. They suggest changing the location of the settings file to somewhere not in the user profile (by default it's stored in My Documents\Visual Studio 2005\Settings\). This is a silly thing to say, since the whole point of using roaming profiles is for settings to follow you around between machines, and moving the settings file out of the roaming profile will mean it won't follow you around.

So, what can we do? Well, we can use H:\ to store the settings file.

To save people the trouble of doing all the steps manually, what follows is a quick guide to performing this on the ITEE Student Network. Note that this has not been heavily tested in all circumstances, and we'd appreciate feedback from everyone who tries these steps to determine if this does in fact work for you and if there were any side effects. Note if you do experience a problem with this procedure, you'll need to reset your profile (as per the instructions in the FAQ.)

  1. Run Visual Studio 2005 at least once, then close it down. If you've previously used it with your roaming profile, you can skip this step.
  2. Run this batch file: VS2K5_rp_firstuse.bat
  3. Check you have a H:\VS2K5 folder and that it contains a file called CurrentSettings.vssettings
    • If not and you skipped Step 1, start over from Step 1.
    • If not and you did perform Step 1, email student-helpdesk@itee.uq.edu.au with your name, login, and student number.
  4. Merge this registry file: VS2K5_rp_firstuse.reg
  5. Start up Visual Studio 2005 and make sure you don't get an error message about a missing setup file.

At this point you should be able to log off, and then log onto another machine and start Visual Studio 2005 without the annoying message. If you still receive the message after following these instructions (and you didn't get any errors during the 5 steps above), email student-helpdesk@itee.uq.edu.au with your name, login, and student number and a description of the problem.